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Введение.

Источник смещения компании «Сконтел» предназначен для управления однофотонными детекторами, а также болометрическими детекторами в составе таких приборов как single photon registration system for visible and near infrared ranges, cryostat-based fast receivers for far and mid-infrared ranges.

Программное обеспечение позволяет управлять источниками смещения, а также мощностью печки, используемой при работе с болометрическим детектором. Помимо этого существует возможность сбора данных (значения тока, напряжения детекторов, давление, температура, напряжение печки). Для управления и сбора данных используется 2 программы: ControlCenter.exe и Measure.exe. Первая предназначена для управления источником смещения, вторая  - для сбора данных и отображения их в графическом виде. Для написания собственных приложений, позволяющих комбинировать разнообразные приборы в комплект программного обеспечения входит пример управления источником смещения выполненный в среде LabView. В комплект программного обеспечения также  входит динамическая библиотека biasbox.dll, с помощью которой возможно использование источника смещения в таких средах разработки программного обеспечения как VB, VC, C Builder, Delphi  и прочее. Помимо этого в комплект программного обеспечения включены программы необходимые для изменения/восстановления начальных калибровок источника смещения (CalibrManager.exe), калибровки источника смещения (calibr.exe), а также средство обновления программного обеспечения источника смещения (Programer.exe).  Более подробно об установке  программного обеспечения рассказано в последующих разделах описания.
Hardware setup.
Драйвер
Для установки коробки смещения необходимо первоначально скачать последнюю версию  драйвера, которую можно найти пройдя по ссылке: http://www.ftdichip.com/Drivers/D2XX.htm (и выбрать драйвер FT232R для вашей операционной системы. На январь 2010 года был доступен драйвер версии 2.06.00 для операционных систем Windows Server 2008 R2, Windows 7, Windows 7 x64, Windows Server 2008, Windows Server 2008 x64, Windows Vista, Windows Vista x64, Windows XP, Windows XP x64, Windows 2000, Windows Server 2003, Windows Server 2003 x64. Для других операционных систем программное обеспечение не тестировалось. При использовании других операционных систем о результате работы просьба сообщить производителям по электронной почте scontel@scontel.ru.
Установка драйвера

Процесс установки драйвера для различных операционных систем подробно описан на странице http://www.ftdichip.com/Documents/InstallGuides.htm. 

Использование программы ControlCenter.exe.
Для управления и отображения данных с источника смещения необходимы 2 программы: ControlCenter.exe и Measure.exe. Стоит отметить, что использование программного обеспечения не отключает возможность управления источником смещения с помощью ручек и кнопок, находящихся на самом приборе. Общий вид рабочего окна программы ControlCenter.exe представлен на рисунке ниже.
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Описание элементов управления

Устройства управления и индикации источником смещения сгруппированы в блоки (Channel1, Channel2, P&T, Heater). Изготовляемый нами источник смещения универсальный и позволяет работать как с болометрическими системами, так и с однофотонными приемными системами. Программа для компьютера также позволяет работать с обоими типами приемных систем. Необходимо лишь отключить ненужные блоки управления. Включение и отключение блоков производится в меню File>Configure… Стоит особо отметить, что в случае одноканальных систем из-за удобства  используется Channel2.
Блок управления каналом представляет собой 2 метки, отображающих значение тока и напряжения смещения, а также набор кнопок и колесико прокрутки. 
Кнопка I – U, предназначена для выбора режима стабилизации источника смещения и одновременно для отображения режима стабилизации (при нажатии на кнопку I, режим стабилизации меняется на стабилизацию напряжения, а надпись на кнопке меняется на U и наоборот). 
Кнопка O – S предназначена для включения – снятия закоротки. При этом надпись на кнопке показывает текущее состояние: O -  соответствует открытому концу источника смещения, S – закороченному. 

Кнопка Set0 предназначена для установки нулевой величины смещения. В случае когда выбран режим стабилизации тока величина тока должна сброситься в 0, иначе напряжение будет сброшено в 0. Ноль тока и напряжения могут не совпадать, поскольку сам приемник обладает низкой температурой и различного рода термоэлектрические эффекты могут приводить к постоянному смещению ноля, в любом случае отображаемые на индикаторе значения тока и напряжения соответствуют истинным источником тока и напряжения на выходе источника смещения.

Кнопка Set предназначена для установки произвольного значения тока или напряжения в зависимости от выбранного режима стабилизации. При нажатии на эту кнопку появляется диалоговое окно представленное ниже, в котором можно указать величину тока – напряжения и при нажатии на кнопку OK, это значение будет установлено. 
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Справа от блока управления каналом находится элемент управления – колесико прокрутки. При наведении на него курсора мыши и вращении колесика прокрутки мыши значения тока-напряжения (в зависимости от выбранного режима стабилизации) увеличиваются или уменьшаются (в зависимости от направления вращения колесика мыши). При нажатии клавиши клавиатуры Ctrl скорость прокрутки увеличивается.

Блок P&T предназначен для индикации значений тока и напряжения. Используется этот блок только при работе с однофотонными детекторами для контроля температуры в случае когда идет откачка паров гелия. Скрыть этот блок можно в меню File>Configure…
Блок Heater предназначен для индикации и управления напряжением печки. Используется только в системах с болометрическим детектором. Скрыть этот блок можно в меню File>Configure… Управление напряжением производится при помощи колесика прокрутки, расположенного справа от блока Heater аналогично тому как это делается для блоков источника смещения. 
Описание пунктов меню.

Пункт меню File>Configure… предназначен для конфигурации блоков программы. При выборе этого пункта меню появляется диалоговое окно, представленное ниже. В этом окне можно выбрать необходимые для работы блоки. Информация о выбранных блоках сохраняется и после перезагрузки программы. В дальнейшем планируется сделать автоопределение элементов управления и индикации источника смещения и этот пункт меню будет исключен из программы.
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 Пункт меню File>Window предназначен для выбора программы осуществляющей вывод и накопление данных. При выборе этого пункта меню открывается диалоговое окно, представленное ниже. В строке ввода диалогового окна необходимо полностью или частично указать заголовок окна-приемника. Представленный пример предназначен для использования программы совместно с программой Measure.exe. Также информацию можно передавать и в свое приложение. Информация о значении тока, напряжения, давления, температуры и напряжения печки передается строковой переменной в виде ‘U1=Value’#9’I1=Value’#9‘U2=Value’#9’I2=Value’#9‘P=Value’#9’T=Value’#9‘HEATER=Value’, где Value – значение величины, #9 – разделительный символ (табулятор).
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Пример приема данных в своем приложении написанный на языке Delphi2009 (стоит помнить, что в этом версии среды программирования строки переведены в формат Unicode).
	Uses Windows;

…

TFmMain = class(TForm)

…

  Procedure ReceiveMessage (var Msg: TMessage); message
  WM_COPYDATA;

…

end

procedure TfmMain.ReceiveMessage (var Msg: TMessage);

var
  pcd : PCopyDataStruct;

  Pch : Pchar;

  Str : string;

  Len : integer;

begin

  pcd := PCopyDataStruct(Msg.LParam);

  Pch := Pchar(pcd.lpData);

  Str := Pch;

  Len := (pcd.cbData-1) div 2;

  delete(str, len+1, length(str)-len);

end;


Пункт меню File>Sweep предназначен для осуществления развертки тока-напряжения (в зависимости от выбранного режима стабилизации). При нажатии на этот пункт меню возникает диалоговое окно, представленное ниже:
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При помощи радиокнопок Channel1 и Channel2 выбирается канал, на котором будет произведена развертка тока-напряжения. В строке выбора Start указывается начальное значение развертываемой величины, в строке Stop – конечное, строка Step – показывает шаг перестройки. При нажатии на кнопку старт начинается развертка тока-напряжения. При этом диалоговое окно Sweep скрывается. Другие элементы управления программы остаются недоступными до окончания процесса развертки. Данная функция предназначена для автоматического построения вольт амперных характеристик. 

Пункт меню File>Exit предназначен для выхода из программы.

Пункт меню Help>About выводит информацию о программе и производителе. Закрыть появившееся окно можно кликнув мышкой на любой точке возникшего окна. 
Использование программы Measure.exe
Программа Measure.exe предназначена для сбора данных, отображения в графическом виде и их хранения. Изначально программа была написана для внутреннего пользования для работы с многоканальным вольтметром собственного производства «Corobo4ka». Со временем функциональность программы была расширена и оказалось, что в ряде экспериментов она удобна не только для сбора данных, но и для простейшей обработки получаемых величин. В настоящее время программа подразумевает возможность подсоединения разнообразных приборов. Ведется работа над включением в список поддерживаемых приборов и источника смещения. Рабочее окно программы представлено на рисунке снизу. 
Программа использует MDI технологию, при которой имеется главное окно программы и дочерние окна (далее будем называть их рабочими окнами программы). По подобной же технологии устроены такие распространенные офисные приложения как MS Word, MS Excel и другие. Материнское окно программы занимается управлением всеми инициализированными приборами, сбором данных и распределением ее между дочерними окнами, которые в свою очередь занимаются хранением и иотображением информации. 
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Описание пунктов меню и кнопок панели инструментов.
Пункт меню File>New, а также кнопка [image: image7.png]


 открывают диалоговое окно создания нового рабочего окна. Подробно описание особенностей работы с этим окном описано ниже в разделе «Создание нового рабочего окна».
Пункт меню File>Open, а также кнопка вызывают [image: image8.png]


 стандартное диалоговое окно открытия файла. Файл должен иметь расширение *.v3d. Данные в файле хранятся в закодированном виде и открыть этот файл возможно лишь программой Measure.exe.
Пункт меню File>Save, а также кнопка [image: image9.png]


 используются для сохранения данных в формате *.v3d. Если файл был открыт ранее, то старый файл будет перезаписан новым. В случае, когда работа идет с абсолютно новым файлом, будет вызван стандартный диалог сохранения данных, в котором пользователю будет предоставлена возможность выбрать директорию для хранения файла и его имя.
Пункт меню File>Save as… предназначен для вызова стандартного диалога сохранения данных, в котором пользователю будет предоставлена возможность выбрать директорию для хранения файла и его имя.

Пункт меню File>Print и кнопка[image: image10.png]


 вызывают стандартное диалоговое окно печати на принтере и предназначено для печати активного рабочего окна программы. 

Пункт меню File>Exit предназначен для выхода из программы. При выходе пользователю будет представлена возможность сохранить данные.

Пункт меню Tools>Reading, а также кнопка [image: image11.png]


 инициализируют подключенные устройства и запускают чтение данных в соответствии с настройками подключенных устройств. Повторный выбор пункта меню Tools>Reading или нажатие на кнопку [image: image12.png]


 останавливает процесс чтения данных.

 Пункт меню Tools>Recording, а также кнопка [image: image13.png]


 начинают процесс записи данных. При этом возникает диалоговое окно, показанное ниже. В диалоговом окне предлагается указать название для собираемого набора точек (далее кривой(Curve)). По умолчанию предлагается в качестве названия кривой указать текущую дату и время. При нажатии на кнопку OK начинается запись данных во все окна, открытых для записи. При этом в этих окнах добавляется кривая с соответствующим названием. Нажатие кнопки Cancel отменяет процесс записи данных. Повторный выбор пункта меню Tools> Recording или нажатие на кнопку [image: image14.png]


 останавливает процесс записи данных.
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Пункт меню Tools>Options, а также кнопка [image: image16.png]


 вызывают диалоговое окно Options более подробно о возможностях этого окна и работе с ним рассказано в разделе «Описание диалогового окна Options».
Пункт меню Window>Cascade, а также кнопка [image: image17.png]


 размещают все открытые рабочие окна каскадом.
Пункт меню Window>Tile Horizontal, а также кнопка [image: image18.png]


 размещают все открытые рабочие окна деля рабочий экран в горизонтальном направлении.
Пункт меню Window>Tile Vertical, а также кнопка [image: image19.png]


 размещают все открытые рабочие окна деля рабочий экран в вертикальном направлении.

Ниже разделителя в пункте меню Windows расположены пункты меню, соответствующие названиям всех созданных рабочих окон. При выборе пункта меню, соответствующее ему рабочее окно выйдет на передний план.

Пункт меню Help>Help Topic вызывает окно, в котором указаны некоторые особенности с работой программы (на русском языке).

Пункт меню Help>Update вызывает диалоговое окно обновления, показанное ниже. При этом программа подсоединяется к Интернету и сравнивает вашу версию программы с последней доступной версией на сайте компании «СКОНТЕЛ», при наличии новой версии появится возможность обновления программы,. При нажатии на кнопку Download, в каталог, в котором находится Measure.exe будет скачана программа обновления. После чего открытый вами файл будет сохранен и основная программа закрыта. После успешной установки программы Measure.exe будет запущена вновь со всеми восстановленными данными. Убедительная просьба при обнаружении ошибок в работе программы сообщать об этом авторам по адресу scontel@scontel.ru. Это позволит нам создать более качественное программное обеспечение и обновление, включающее исправленные ошибки выйдет в скором времени. 
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Пункт меню Help>About вызывает окно, в котором содержится краткая информация об авторе, а также историю версий программы (на русском языке).
Описание диалогового окна Options.
Диалоговое окно Options вызывается при выборе пункта меню Tools>Options или при нажатии кнопки [image: image21.png]


 на панели инструментов. При первом запуске программы, при условии, что рабочие окна не созданы диалоговое окно Options выглядит следующим образом. 
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В левой части диалогового окна Options располагается дерево ресурсов. Оно представлено 5 элементами: Devices, Windows, Filters, Internal Variable и External Variable. При выборе любого элемента дерево окно справа меняется. 
Элемент дерева ресурсов Devices
Элемент дерева Devices предназначен для добавления и удаления активных устройств. При нажатии на кнопку Add Device возникает диалоговое окно выбора устройства, в котором можно выбрать тип устройства, а также серийный номер уже подключенного устройства этого типа. Для версии программы 4.2.0.5 существует возможность добавления только устройств типа Corobo4ka. Для более поздних версий программы количество поддерживаемых устройств будет увеличено. При добавлении устройств появится возможность изменения настроек устройства. Устройство при этом отображается в дереве ресурсов в левой части окна. Кнопка Delete Device предназначена для удаления выбранного устройства из списка. Кнопка Init предназначена для первоначальной инициализации выбранного устройства. Полоска прогресса в блоке Opacity настраивает прозрачность большинства диалоговых окон, используется в декоративных целях. Ниже описаны некоторые приборы, управление которыми реализовано к моменту написания этой инструкции.
Многоканальный вольтметр «Corobo4ka».

При выборе устройства типа Corobo4ka в дереве объектов окно Options изменяется на ниже приведенное. В блоке Channels находятся 4 CheckBox, в которых выбираются необходимые для работы каналы измерительного устройства. Стоит учесть, что при уменьшении количества работающих каналов частота опроса каждого из каналов увеличивается обратно пропорционально числу работающих каналов. В блоке Voltmeter&Spectrum находятся элементы управления позволяющие менять настройки устройства считывания. Time Constant – время усреднения для работы вольтметра в режиме самописца. Это время между двумя ближайшими точками любого из каналов. Делать это время очень малым менее 20мс неправильно, поскольку это приведет к существенной нагрузке на компьютер, к тому же точность определения времени гарантированная операционной системой Windows порядка 10мс. Conversion Time – время между двумя последовательными преобразованиями. Диапазон значений этой величины 82-2600 мкс. Увеличение этой величины приводит к уменьшению шумов преобразования и снижению максимальной частоты при построении спектров. При этом максимальная частота спектра рассчитывается как Fmax=1/(2*Conversion Time*NChannel), где NChannel – количество используемых каналов. То есть при включенном одном канале и времени преобразования 1000 мс максимальная частота спектра будет равна 500 Гц. 

Блок Channel calibrating предназначен для калибровки на ноль каждого из каналов вольтметра. При этом на вход вольтметра необходимо поместить закоротку либо небольшое постоянное сопротивление, в выпадающем списке выбрать соответствующий ему номер канала и нажать на кнопку Calibrate. Это приведет к вычислению новых калибровочных коэффициентов, хранящихся в памяти вольтметра и дальнейшему их использованию при работе программы.
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Элемент дерева ресурсов Windows.
При выборе в дереве ресурсов элемента Windows появится окно с предложением выбрать одно из рабочих окон для редактирования его настроек. Детальное рассмотрение настроек рабочих окон будет проведено в разделе  «Создание нового рабочего окна».

Элемент дерева ресурсов Filters

Этот элемент дерева ресурсов используется только совместно с многоканальным вольтметром «Corobo4ka» и предназначен для составления разнообразных цифровых фильтров для обработки входного сигнала. В качестве фильтра могут быть выбраны фильтр низких частот, фильтр высоких частот, полоснозаградительный или полоснопропускающий фильтры Баттерворта, а также любые последовательные комбинации этих фильтров. На рисунке ниже представлен пример окна открывающегося при выборе элемента дерева Filters.
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В списке указывается описание включенных фильтров. При нажатии на кнопку Add возникает диалоговое окно создания фильтра, представленное ниже. Пользователю предлагается выбрать тип фильтра, его граничные частоты, на которых коэффициент пропускания фильтра равен -3dB, а также порядок фильтра (необходимо, чтобы порядок фильтра был четным). Следует помнить, что с увеличением порядка фильтра крутизна спада увеличивается, но это приводит к увеличению сложности вычислений. Также при увеличении порядка фильтра повышаются требования к точности расчета коэффициентов фильтра, что может привести к расбалансировке и возбуждению фильтра.

[image: image25.png]addFilter
IWI
rlsn_





При нажатии на кнопку Edit возникает диалоговое окно редактирования, в котором можно изменить параметры выделенного цифрового фильтра. Альтернативой для вызова окна редактирования фильтра служит двойной щелчок курсора мыши на описании фильтра в списке.
При нажатии на кнопку Delete, или нажатие клавиши клавиатуры Del выделенные фильтры удаляются.

В качестве примера сложного фильтра можно создать 2 полоснозаградительных фильтра со следующими характеристиками: для первого фильтра F1=45Hz, F2=55Hz, N=4, для второго фильтра F1=95Hz, F2=105Hz, N=4. Такой составной фильтр позволяет избавиться от сетевой наводки и ее второй гармоники.

Элемент дерева ресурсов Internal Variables
При выборе в дереве ресурсов элемента Internal Variables появится окно представленное ниже. Внутренние переменные программы используются для произведения простейших действий над всеми входными данными программы, такими как данные подключенных приборов и внешние переменные, передаваемые сторонними приложениями. Более подробно о внешних переменных и методах работы с ними будет рассказано в разделе Элемент дерева ресурсов External Variables. С входными переменными можно производить следующие математические действия: сумма, разность, произведение, деление, возведение в степень и операции со скобками. 
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При нажатии на кнопку Add появляется диалоговое окно создания новой переменной, представленное ниже. Пользователю предоставляется возможность указать имя новой переменной и ее значение. При использовании значений какого либо канала входных данных название переменной должно стоять в скобках <> и должно полностью соответствовать названию переменной как это было бы при написании названия оси рабочего окна программы. Внешние и внутренние переменные указываются без Ext. Variable и Int. Variable. 
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	ПРИМЕР:

A=<Instr0: Channel1>+<Instr0: Channel2> 

B=<A>+1  


При нажатии на кнопку Edit возникает диалоговое окно редактирования, в котором можно изменить как имя так и значение переменной. Альтернативой для вызова окна редактирования переменной служит двойной щелчок курсора мыши на соответствующей строке в списке.

При нажатии на кнопку Delete, или нажатие клавиши клавиатуры Del выделенные переменные удаляются.

Элемент дерева ресурсов External Variables
При выборе в дереве ресурсов элемента External Variables появится окно представленное ниже. Внешние переменные используются для получения данных от сторонних приложений. Пример такого симбиоза демонстрирует сочетание программы с приложением ControlCenter.exe. Программа ControlCenter.exe пересылает данные для 7 переменных: I1, U1, I2, U2, HEATER, P, T.
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При нажатии на кнопку Add появляется диалоговое окно создания новой внешней переменной, представленное ниже. Пользователю предоставляется возможность указать имя новой переменной.
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При нажатии на кнопку Edit возникает диалоговое окно редактирования, в котором можно изменить имя внешней переменной. Альтернативой для вызова окна редактирования внешней переменной служит двойной щелчок курсора мыши на соответствующей строке в списке.

При нажатии на кнопку Delete, или нажатие клавиши клавиатуры Del выделенные переменные удаляются.

Ниже представлен пример того, как можно передать значение переменной из сторонней программы в программу Measure.exe. Пример написан с использованием компилятора Delphi2009. При необходимости пересылки нескольких переменных они разделяются символом табуляции.
	Uses Windows;

…
procedure FindWindow(WindowToExport: string; var Handle: THandle);

  var stop:boolean;

      nstr: array [0..255] of char;

begin
  Handle:=fmMain.Handle;

  Stop:=False;

  while (not stop) and (Handle<>0) do

    begin
      Handle:=GetWindow(Handle,GW_HWNDNEXT);

      GetWindowText(Handle,nstr,255);

      if pos(WindowToExport,strpas(nstr))<>0

        then stop:=true

    end;

end;

procedure SendData(Name: string; Value:real);

  var Hand: THandle;

      str : string;

      cd  : TCopyDataStruct; 

begin
  FindWindow(‘Measure’,Hand);
  if Hand<>0 then
    begin
      str:=Name+’=’+floattostr(Value);

      cd.cbData := length(str)*sizeof(char)+1;

      cd.lpData := Pchar(str);

      SendMessage(Hand, WM_COPYDATA, 0, LParam(@cd));

    end;

end;


Создание нового рабочего окна.
Пункт меню File>New, а также кнопка [image: image30.png]


 открывают диалоговое окно создания нового рабочего окна, представленное ниже. В верхней части диалогового окна представлена таблица с основными настройками. В строке Dimension of Window указывается тип создаваемого окна. При нажатии на правой части этой строки возникает выпадающий список с возможностью выбора 4 типов создаваемого окна: 2D, 3D, Oscilloscope и Spectrum. При выборе типа 2D будет создано окно с двумя координатами (X (горизонтальная ось) и Y (вертикальная ось)), при выборе типа окна 3D будет создано окно с тремя координатами (X (горизонтальная ось), Y (вертикальная ось) и ось Z, направленная перпендикулярно экрану монитора, при этом информация по этой оси отображается цветом), при выборе окна типа Oscilloscope будет создано двумерное окно, в котором будет строится быстрая развертка сигнала (работает только с устройством «Corobo4ka»), при выборе окна типа Spectrum будет создано двумерное окно, в котором будет строится спектр принимаемого сигнала (работает только с устройством «Corobo4ka»),
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Строки Axis-X, Axis-Y и Axis-Z (в случае трехмерного окна) показывают значение какой переменной будет отложено по данной оси. Щелчок курсора мыши на строке приводит к появлению контекстного меню, как это показано на рисунке ниже, при этом у пользователя имеется возможность выбрать в качестве используемой переменной для выбранного канала любую из внутренних, внешних переменных, время или данные подсоединенных устройств.
[image: image32.png][Dimension of Window

5

B

Corobodka: CO040001

==

Time

Int. Variables

Backaround Color

Grid Color

[Curves Colar

v Active
W wite
WV StatusBar Visible.

ok

Coca

3

e=
&

2
w
HEATER

ST





Поле Background Color отвечает за фоновый цвет создаваемого окна (по умолчанию белый). Щелчок мыши на окрашенном элементе приводит к появлению выпадающего списка, в котором можно выбрать наиболее привлекательный пользователю цвет. То же самое касается и полей Grid Color и Curves Color. Первое отвечает за цвет сетки, второе за цвет кривых, которыми будут отображаться данные. После можно будет выбрать индивидуальный цвет для каждой кривой.

В правой нижней части диалогового окна расположены 3 CheckBoxes. Галочка Active показывает активно ли окно и готово ли оно для приема данных. При отключении этой опции данные окном не принимаются. Галочка Write показывает будет ли производиться запись в это окно при выборе пункта меню Tools>Recording или нажатии кнопки [image: image33.png]


. Галочка StatusBas Visible указывает появится ли строка состояния в нижней части созданного окна.
Нажатие кнопки Ok приводит к созданию рабочего окна , показанного ниже. Для смещения сетки по горизонтали и вертикали используются клавиши клавиатуры со стрелками. Также можно зажать на колесико мышки и, передвигая ее, смещать координатную сетку. Изменять масштаб координатной сетки по горизонтали или вертикали можно нажимая клавиши клавиатуры со стрелками при нажатой клавише Shift.
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В нижней части окна находится строка состояний, в которой отображается текущее значение получаемых данных. Данные обновляются в момент, когда на каждую из осей координат приходит не менее одного значения. После этого счетчик значений для каждой оси сбрасывается. В центре экрана находится маркер. Маркер показывает текущее значение каждой из координат. Нажатие правой клавиши мыши на поле рабочего окна приводит к появлению контекстного меню показанному ниже.

[image: image35.png]Gopy Curves:  CHl+0
Paste Clik+y

ClearAll

Curves Manager
Selector Enabled Ctrl+E

Options





Пункт меню Copy Curves копирует данные в буфер обмена данных в собственном формате программы. Данный пункт меню предназначен для переноса данных из одного рабочего окна в другое. 

Пункт меню Paste вставляет данные из буфера обмена данных, при этом данные могут быть как в собственном формате программы, так и в текстовом формате (при этом данные должны располагаться в 2 столбцах: первый – ось X, второй – ось Y (в случае трехмерного окна, данные должны находиться в 3 столбцах), разделенные либо пробелом, либо знаком табуляции, в конце каждой строке должен стоять символ переноса строки).
Пункт меню ClearAll удаляет все существующие кривые.
Пункт меню CurvesManager открывает окно диспетчера кривых, показанное ниже. В списке слева перечислены все существующие кривые. Символы левее названия кривой означают следующее: [image: image36.png]


 –  цвет кривой (по щелчку курсором мыши на этой пиктограмме появляется контекстное меню, в котором можно выбрать цвет кривой), [image: image37.png]


 – символ, обозначающий видимость точек кривой (если кружок желтый, то точки видимы, черный кружок означает невидимость точек кривой), щелчок курсором мыши на этой пиктограмме меняет состояние видимости кривой на противоположное, [image: image38.png]


 – символ, показывающий соединены ли точки линией друг с другом (символ с маленьким кружочком означает, что линии не соединяются друг с другом), щелчок курсором мыши на этой пиктограмме меняет состояние соединенности точек  кривой на противоположное. Правее названия кривых указаны радиус точек (R) и ширина линии, соединяющих точки (W). Справа по центру расположены 3 строки ввода, позволяющие изменить название кривой, радиус точек, и толщину линии. 
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В верхней правой части окна находятся кнопки позволяющие производить простые действия с кривыми. Нажатие кнопки Join Curves приводит к объединению выделенных кривых в одну, при этом все свойства (цвет, видимость, и т.д.) остаются такими же как и у первой из выделенных в списке кривых.

Нажатие кнопки Delete или клавиши Del на клавиатуре приводит к удалению выделенных кривых.

Нажатие кнопки Sort by X приводит к сортировке кривой по возрастанию координаты X.
Нажатие кнопки Sort by Y приводит к сортировке кривой по возрастанию координаты Y.
Кнопка A*X+B  предназначена для проведения линейных трансформаций кривых. При этом открывается диалоговое окно, представленное ниже. Введя коэффициенты в строки ввода и нажав на кнопку Do It, можно провести линейную трансформацию выделенных кривых.
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Следующие функции достаточно специфичны и вряд ли будут иметь широкое практическое применение. Кнопка AVAR строит вариацию Алана от выделенных  кривых. Math Calc производит вычисление среднего значения и среднеквадратичного отклонения ординат выделенных кривых. AutoCORR строит автокорреляционную функцию.

В нижней части окна расположены кнопки Copy и Copy as Text. Первая предназначена для копирования данных выделенных кривых в буфер обмена данных в собственном формате. Вторая кнопка предназначена для копирования данных в буфер обмена данных в текстовом формате с возможностью последующей вставки в текстовый редактор. Между этими двумя процессами существует большая разница во времени выполнения команд в пользу копирования в собственном формате.
Окно диспетчера кривых для трехмерных графиков несколько отличается. Оно представлено на рисунке ниже. Данные в трехмерных окнах могут отображаться двумя способами – градиентная раскраска (при этом цвет точек плавно меняется от черного до цвета кривой, обозначенного самой левой пиктограммой левее названия кривой, черный цвет соответствует минимальному значению, цвет кривой - максимальному), либо раскраска в цветах радуги (при этом фиолетовому цвету соответствует минимальное значение, красному - максимальное). Выбор способа представления данных производится по щелчку на самой правой пиктограмме левее имени кривой. Третья слева пиктограмма отвечает за отображение точек, если она принимает вид квадрата, то точки отображаются прямоугольниками, со сторонами RX и RY соответственно. В случае, когда эта пиктограмма принимает вид кружка, точки отображаются в виде кругов с радиусом R. В строках ввода в правой части окна можно изменять параметры кривой.
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Назначение кнопок в правой части окна такое же как и для диспетчера кривых двумерного рабочего окна. Появившаяся кнопка Gauss позволяет делать гауссово размытие кривой. При нажатии этой кнопки возникает следующее диалоговое окно:
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Границы в которых происходит построение размытого изображения определяется полями Xmin, Xmax, Ymin, Ymax, при этом при размытии учитываются и точки кривой вне выбранного прямоугольника. NX и NY определяют количество точек по каждой из сторон прямоугольника, в котором происходит построение гауссова размытия. При этом общее число точек, в которых будет произведено вычисление равняется NX*NY. sigmaX и sigmaY – параметры размытия по каждой из осей. Чем больше этот параметр, тем более размытым получится результат. Стоит выбирать эти значения порядка среднего расстояния между точками кривой. По нажатию кнопки Apply происходит вычисление матрицы, соответствующей размытому изображению. Результат представляется в виде кривой. Использование этой функции удобно, когда имеется ряд дискретных точек, а необходимо получить непрерывное изображение.
Вернемся к контекстному меню рабочего окна. При нажатии на пункт Selector Enabled контекстное меню становится следующим:
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При этом появляется возможность выбора точек прямоугольником при нажатой левой клавиши мыши. Далее можно удалить точки внутри прямоугольника (Пункт меню Delete) или вне прямоугольника (пункт меню Delete Outside).

Пункт меню Options соответствует выбору пункта меню Tools>Options или нажатию на кнопку [image: image44.png]


, с последующим выбором активного окна. При этом внешний вид диалогового окна Options становится таким как показано на рисунке внизу.
[image: image45.png]ns
Devizs
Windows
QU2 5 Y
Fires
R——
Enemal Vaiatles

2

e o o

<z sackround [ || 7 Ackve
B A  Wid

Y i g | ¥ StatusBar

e & Maker

[ietos | Metrod2

% [ e 8 e

v e 5

o L





Блок Axises позволяет выбрать источник данных для соответствующей оси рабочего окна. Щелчок курсором мыши на строках ввода в этом блоке приводит к появлению контекстного меню, аналогичного тому, которое появляется в диалоговом окне создания нового окна.
Блок Colors позволяет выбрать цветовую гамму для рабочего окна. Щелчок курсором мыши на цветовой панели вблизи надписей BackGround, Grid и Curves приводит к появлению контекстного меню с возможностью выбора цвета. Выбранный цвет будет установлен как основной для фона рабочего окна, координатной сетки и цвета создаваемых кривых соответственно.

Блок Options позволяет изменять следующие свойства рабочего окна. Галочка Active показывает активно ли окно и готово ли оно для приема данных. При отключении этой опции данные окном не принимаются. Галочка Write показывает будет ли производиться запись в это окно при выборе пункта меню Tools>Recording или нажатии кнопки [image: image46.png]


. Галочка StatusBas указывает появится ли строка состояния в нижней части созданного окна. Галочка Marker указывает на видимость маркера в рабочем окне программы. 
Все свойства рабочего окна меняются только после нажатия на кнопку Apply или Ok в нижней части диалогового окна.

В центральной части окна находится блок линейной трансформации входных данных. Существует 2 способа линейной трансформации входных данных. Первый способ, реализованный на вкладке Method1, подразумевает использование формулы X=A*X+B для каждой из осей, где коэффициенты A и B задаются пользователем. Второй способ, реализованный на вкладке Method2, связывает пару точек нетрансформированных данных с парой точек выходных данных. Изменения вступают в силу только после нажатия на кнопку Apply в этом блоке. Для трехмерных окон в этом блоке также указывается минимальное и максимальное значения оси Z.
	ПРИМЕР:

Линейная трансформация вида 1000*X+0 вторым методом будет записана как

Xold1 = 0    Xnew1=0

Xold2 = 1    Xnew2=1000


Пакет компонентов для работы в среде LabView
Для работы в среде LabView разработан пакет компонентов виртуальных инструментов обеспечивающих управление и сбор данных источником смещения. В составе комплекта программного обеспечения subVI, являющихся оболочками к функциям динамической библиотеки biasbox.dll. 

Для организации работы по принципу «потока данных», все subVI имею входной и выходной терминал ошибки, за исключением bb_Open (имеет только выходной терминал) и bb_Close (имеет только входной терминал). Терминал ошибки является кластером со следующими полями:
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ERROR - принимает значение TRUE в случае возникновения ошибки обмена.

CODE - возвращает код ошибки (см. описание biasbox.dll). 

SOURCE – Возвращает текстовое название subVI вызвавшего ошибку.

Виртуальный инструмент bb_Open.vi [image: image47.jpg]


 предназначен для инициализации интерфейса обмена данными. Имеет один выходной терминал ошибки.
Виртуальный инструмент bb_GetData.vi [image: image48.jpg]


 предназначен для получения данных от источника смещения. Имеет входной и выходной терминал ошибки.

DATA – Массив кластеров с данными от прибора. Кластеры имею вид:
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Ix – значение тока на канале х в A.

Ux – значение напряжения на канале х в V.

P – значение давления mBar.

T — значение температуры в К.

R – сопротивление терморезистора в Ohm.

HEATER – напряжение на печке в V.

BATx – напряжения в mV батарей положительного (P) и отрицательного питания (N).

STATUS – Режимы стабилизации источников и нуля на выходе (см. описание на biasbox.dll). 

ERROR – Ошибки в работе прибора (см. описание на biasbox.dll).

NUMBER – количество кластеров с данными во входном буфере.

Виртуальный инструмент bb_Value.vi [image: image50.jpg]


 устанавливает значение тока или напряжения в зависимости от выбранного режима работы. Имеет входной и выходной терминал ошибки.

CHANNEL – номер канала (0 или 1).

VALUE – Значение тока или напряжения в зависимости от текущего режима стабилизации.

Виртуальный инструмент bb_SetMode.vi [image: image51.jpg]


 устанавливает режим стабилизации тока-напряжения. Имеет входной и выходной терминал ошибки. 

SET – режим стабилизации: FALSE – по напряжению; TRUE – по току.

CHANNEL – номер канала (0 или 1).

Виртуальный инструмент bb_SetZero.vi [image: image52.jpg]


 устанавливает нулевое значение на выбранном канале. Имеет входной и выходной терминал ошибки.

SET – установка нуля (короткое замыкание выхода источника): FALSE – выход разомкнут; TRUE – выход замкнут.

CHANNEL – номер канала (0 или 1).

Виртуальный инструмент bb_Close.vi [image: image53.jpg]


 предназначена для закрытия интерфейса и завершения процесса обмена данными. Имеет выходной терминал ошибки.

В комплекте поставки приведен простой пример того, как организовать работу источника смещения (файл simple_demo.vi)
 Использование динамической библиотеки данных biasbox.dll
Динамическая библиотека данных biasbox.dll предназначена для работы с источником смещения. При этом имеется возможность создания своих приложений с подключением функций библиотеки, предназначенных для управления и сбора данных источника смещения. Работу с устройством необходимо начать с открытия его, используя функцию bb_Open, завершать работу нужно закрытием устройства, используя команду bb_Close.

Описание функций.
Инициализации интерфейса обмена данными.

  char bb_Open(void);

Возвращаемый параметр равен 1 в случае успешного открытия интерфейса и 0 в случае ошибки.

Закрытие интерфейса и завершение обмена данными.
  char bb_Close(void);

Возвращаемый параметр равен 1 в случае успешного закрытия интерфейса и 0 в случае ошибки.

Получение данных.

  char bb_GetData(PMEASDATA buf);

Входным параметром процедуры является указатель на структуру типа MEASDATA, описанную ниже.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Конфигурация источника смещения.

  char bb_PutData(PCONFIGDATA buf);

Входным параметром процедуры является указатель на структуру типа CONFIGDATA, описанную ниже.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Получение калибровочных констант

  char bb_GetEeConst(PEECONST buf);

Входным параметром процедуры является указатель на структуру типа EECONST, описанную ниже.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Пересылка  калибровочных констант в источник смещения.

  char bb_PutEeConst(PEECONST buf);

Входным параметром процедуры является указатель на структуру типа EECONST, описанную ниже.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Получение таблицы зависимости истинной температуры от показаний датчика температуры.
  char bb_GetEeTable(PUSHORT TempCode,

                      PFLOAT TempData);

Процедура имеет два входных параметра: 
PUSHORT TempCode – указатель на массив из 100 элементов с указанием кодов АЦП датчика температуры.

PFLOAT TempData – указатель на массив из 100 элементов с указанием истинных значений температуры, соответствующим кодам АЦП в массиве TempCode.
Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Передача таблицы зависимости истинной температуры от показаний датчика температуры.

  char bb_PutEeTable(PUSHORT TempCode,

                      PFLOAT TempData);

Процедура имеет два входных параметра: 
PUSHORT TempCode – указатель на массив из 100 элементов с указанием кодов АЦП датчика температуры.

PFLOAT TempData – указатель на массив из 100 элементов с указанием истинных значений температуры, соответствующим кодам АЦП в массиве TempCode.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Сохранение текущих констант в постоянную память источника смещения.

  char bb_SaveEeConst(void);

Процедура выполняется достаточно долго (порядка 10-20сек.)

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Получение данных в формате LabView.
  UINT bb_LVGetData(PMEASDATA buf);

Входным параметром процедуры является указатель на структуру типа MEASDATA, описанную ниже.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки.

Конфигурация источника смещения для среды LabView.

  UINT bb_LVPutData(PCONFIGDATA buf);
Входным параметром процедуры является указатель на структуру типа MEASDATA, описанную ниже.

Возвращаемый параметр равен 1 в случае успешного выполнения функции и 0 в случае ошибки. 
Описание типов данных и констант.
Структуры данных, используемые в динамической библиотеке данных biasbox.dll
typedef struct _MEASDATA

{

  float I1;              //Ток первого канала в мкА

  float U1;              //Напряжение первого канала в мВ
  float I2;              //Ток второго канала в мкА

  float U2;              //Напряжение второго канала в мВ
  float P;               //Давление
  float T;               //Температура
  float R;               //Сопротивление термометра
  unsigned short int BATP; //Заряд положительной батареи аккумулятора(показываемое напряжение необходимо умножить на 10мВ)

  unsigned short int BATN; //Заряд отрицательной батареи аккумулятора(показываемое напряжение необходимо умножить на 10мВ)

  float HEATER;          //Напряжение пески
  unsigned char STATUS;  //Статусный байт (значения битов описаны ниже)

  unsigned char BBERROR;  //Байт ошибок (значение битов описаны ниже)
} MEASDATA, *PMEASDATA;

typedef struct _CONFIGDATA
{

  float I1;              //Ток первого канала в мкА

  float U1;              //Напряжение первого канала в мВ
  float I2;              //Ток второго канала в мкА

  float U2;              //Напряжение второго канала в мВ
  float HEATER;          //Напряжение пески
  unsigned char STATUS;  //Статусный байт (значения битов описаны ниже)

} CONFIGDATA, *PCONFIGDATA;

typedef struct _EECONST

{

  float  I_slope[2]; 
  float  I_int[2];

  float  U_slope[2];

  float  U_int[2];  //калибровочные значения для получения значения токов каналов в мкА из цифровых значений показаний АЦП (разъяснение коэффициентов смотри в разделе «Использование программы calibr.exe и калибровка источника смещения»)
  float  DAC_I_slope[2];

  float  DAC_I_int[2];

  float  DAC_U_slope[2];

  float  DAC_U_int[2];

  float  R_slope;

  float  R_int;

  float  UH_slope;

  float  UH_int;

  float  DAC_UH_slope;

  float  DAC_UH_int;

  float  P_slope;

  float  P_int;

}EECONST, *PEECONST;
Биты статусного байта

Bit0   ENB_CH1    //КАНАЛ 1 ВКЛЮЧЕН

Bit1   ENB_CH2    //КАНАЛ 2 ВКЛЮЧЕН

Bit2   CUR_CH1    //КАНАЛ 1 В СТАБИЛИЗАЦИИ ПО ТОКУ

Bit3   CUR_CH2    //КАНАЛ 2 В СТАБИЛИЗАЦИИ ПО ТОКУ

Bit4   SHORT1     //ЗАКОРОТКА КАНАЛА 1 ВКЛЮЧЕНА
Bit5   SHORT2     //ЗАКОРОТКА КАНАЛА 2 ВКЛЮЧЕНА

Bit7   MAIN_MODE  //РЕЖИМ РАБОТЫ: 1 - РАБОТА 0 – ЗАРЯД              

                    АККУМУЛЯТОРОВ
Биты байта ошибок

Bit0   ADC_1      //ADC1 не отвечает - превышено время ожидания

Bit1   ADC_2      //ADC2 не отвечает - превышено время ожидания

Bit2   ADC_3      //ADC3 не отвечает - превышено время ожидания

Bit3   BATP_ER    //Ошибка зарядного устройства положительных батарей

Bit4   BATN_ER    //Ошибка зарядного устройства отрицательных батарей

Bit5   BATP_CH    //Положительные батарею заряжаются

Bit6   BATN_CH    //Отрицательные батарею заряжаются

Настройка источника смещения при помощи программы Prefences.exe 
 Для полной настройки устройства используется программа prefences.exe. Для использования всех функций этой программы вам понадобятся компьютер, подключенный к сети Internet (обязательно наличие одного порта USB для подключения устройства и одного COM-порта для подключения мультиметра, COM-порт может быть заменен переходником подключенным к USB-порту) с установленными на нем драйверами для микросхемы  FT232R. Также для полной калибровки устройства вам понадобится мультиметр Agilent34401A, подсоединенный к COM-порту компьютера. Наличие подключения к сети Internet  необходимо только для обновления программного обеспечения устройства и отправки калибровочных данных производителю. COM-порт и мультиметр Agilent34401A необходимы лишь в случае калибровки каналов и печки. Далее будет произведено пошаговое описание работы программы.
Шаг 1 – Инициализация.
При запуске программы появляется рабочее окно представленное ниже:
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В окне выводится краткая информация о подключенных к компьютеру устройствах, их количестве, серийном номере и версии прошивки. При запуске программа получает информацию с сайта производителя о последней версии прошивки устройства и отображает эту информацию на экране. Правильная работа программы возможна в случае подключения только одного устройства BiasUnit к компьютеру. В противном случае пользователю будет доступна лишь кнопки «Проверить подключение» и «Exit». При нажатии на кнопку «Проверить подключение» происходит проверка подключенных устройств к компьютеру аналогично тому, как это делается в случае начала работы программы. Кнопка «Exit» осуществляет выход из программы. 

Обнаружение одного устройства FTDI  и при условии не обнаружение устройств BiasUnit соответствует случаю первоначального включения устройства. В этом случае рядом с информацией о подключенных устройствах появляется кнопка «Первоначальная конфигурация FTDI». При нажатии на эту кнопку появляется окно первоначальной конфигурации устройства, в котором нужно лишь указать серийный номер устройства и нажать на кнопку «Config». Следует крайне внимательно подойти к этой операции. Поскольку, в случае если имеется подключенное к компьютеру устройство другого производителя, то оно может быть неправильно инициализировано и в будущем не работать.
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После успешной конфигурации устройства должно произойти автоматическое переподключение устройства. В этом случае, вам возможно придется заново установить драйвера на устройство. При этом программа не будет правильно работать, пока процесс установки драйверов не завершится. 

В случае успешного обнаружения BiasUnit откроется возможность использования программы. При нажатии на кнопку «Update Hardware» происходит подключение к сети Internet. Программа скачивает последнюю версию прошивки для устройства и программирует BiasUnit. Процесс полностью автоматизирован и не требует никаких действий со стороны пользователя. Все этапы процесса протоколируются на форме окна. В случае сбоя обновления программы необходимо связаться с производителем и сообщить на каком этапе происходит сбой обеспечения. В случае успеха форма загрузки примет следующий вид:
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Нажатие на кнопку «Восстановить настройки» открывает диалоговое окно, в котором пользователю предлагается выбрать ранее сохраненный файл настройки в формате *.bbc (старый формат файла настройки, включающий только калибровочную информацию устройства) или *.pref (файл настройки и калибровки). После выбора файла настройки автоматически загрузятся в BiasUnit. Процесс загрузки занимает некоторое время. Для того, чтобы настройки были сохранены в постоянную память устройства необходимо нажать на кнопку «SaveEEPROM», доступную на шагах 2 и 3.
Нажатие на кнопку «Next» позволяет перейти к следующему шагу настройки устройства.

Шаг 2 – Конфигурирование устройства.

При переходе к шагу 2, форма приложения изменится на следующую:
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Для понимания смысла калибровочных коэффициентов следует обратиться к блок-схеме представленной ниже:
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В приведенной схеме сигнал о необходимом значении тока-напряжения идет от компьютера (ПК) в микроконтроллер (МК), расположенным на основной плате источника смещения. В случае автономной работы это значение формируется в самом МК. Причем эти значения являются аналоговыми значениями, выраженными в единицах тока-напряжения. Далее МК использует линейную зависимость и высчитывает цифровой код для установки выходного тока-напряжения при помощи цифро-аналогового преобразователя (ЦАП). Формула применительно к току первого канала выглядит следующим образом: 

I(ЦАП)=DAC_I_slope1*I(МК)+DAC_I_intercept1.

Значения тока-напряжения измеряются при помощи аналого-цифрового преобразователя (АЦП), на выходе которого получается цифровой код. Этот цифровой код переводится в значение тока напряжения по формуле похожей на предыдущую формулу.

I(МК)= I_slope1*I(АЦП)+ I_intercept1.

Калибровка источников смещения заключается в нахождении неизвестных коэффициентов: DAC_X_slopeN, DAC_X_interceptN, X_slopeN, X_interceptN, где X=I,U, а N=1,2. Для получения этих коэффициентов необходимо обязательное наличие мультиметра Agilent34401A. На шаге 1 предлагается выбрать номер COM-порта, к которому подключен Agilent.
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На шаге 2 предлагается выбрать режим калибровки. Для калибровки источника смещения необходимо выбрать пункт «Detectors». Также можно выбрать и количество точек в калибровке. Количество точек задает величину шага перестройки источника смещения во время калибровки. С увеличением числа точек возрастает и точность калибровки, чрезмерное увеличение этого значения приведет к увеличению времени калибровки. Разумно оставить это значение в диапазоне 50-200.
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На шаге 3 необходимо выбрать режим калибровки источника смещения. При этом можно выбрать калибровку напряжения или тока для первого или второго канала. При этом необходимо выход источника смещения подключить к входу мультиметра. Например, при указанном на приведенном ниже рисунке соотношении настроек, необходимо подключить выход канала №1 источника смещения к потенциальным входам мультиметра.
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После нажатия на кнопку «Next», вам предложат еще раз проверить подключение всех приборов.
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Следующим шагом работы, является собственно сам процесс калибровки, при этом вид программы изменится на приведенный ниже. Процесс калибровки занимает некоторое время, процент выполнения работы отображается в левом маленьком окне. В ходе процесса калибровки на графике будут строиться измеряемые величины. Для точек строящихся синим цветом ордината соответствует измеренному мультиметром значению, абсцисса точки соответствует цифровому коду, посылаемому на ЦАП. Для точек строящихся зеленым цветом ордината также соответствует измеряемому мультиметром значению, а абсцисса соответствует цифровому коду, измеряемому при помощи АЦП. Для смещения графика по горизонтали или вертикали удерживайте клавиши клавиатуры со стрелками. Также можно перемещать график при нажатой центральной клавиши мыши (при нажатии на колесико мыши). Для изменения масштаба по горизонтали или вертикали удерживая клавишу Shift нажмите соответствующую клавишу со стрелкой. Во время процесса калибровки может произойти сбой, связанный с ошибкой приема-передачи команды. В этот момент может произойти выброс, который повлияет на конечную калибровку устройства. Вероятность этого достаточно мала, но контролировать процесс все же необходимо. В случае возникновения выброса неправильную точку можно удалить, для этого сначала в контекстном меню графика следует выбрать опцию «Selector Enabled». После этого нужно рамкой выделить ненужные точки и удалить их при помощи контекстного меню. По окончанию процесса калибровки происходит автоматическое вычисление нужных коэффициентов и запись их в устройство смещения. Результат калибровки можно проверить, сравнивая показания индикатора и мультиметра.
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Калибровка печки

В случае, когда в устройстве используется печка (примером работы устройства в таком режиме может быть использование его для работы с прямым детекторным приемником, в котором необходим дополнительный подогрев детектора), необходимо провести калибровку напряжения на печке. Калибровка производится аналогично описанному в п.2.1. Отличием является то, что в шаге 2 необходимо выбрать «Heater», потенциальные входы мультиметра Agilent34401A необходимо подсоединить к выходу печки. В ходе калибровки часто может наблюдаться нелинейность синей кривой. После окончания калибровки обе кривые автоматически апроксимируются прямой линией. Нелинейность синей кривой приведет к тому что шаг перестройки печки будет нелинеен. При большем значении напряжения шаг перестройки меньше. Такого рода нелинейность в эксперименте бывает более удобна, чем линейная зависимость шага перестройки. Стоит отметить, что зеленая кривая (кривая показаний АЦП) остается линейной, т.е. отображаемые на дисплее значения напряжения печки являются истинными.
Калибровка датчика давления.

Зависимость выходного напряжения датчика давления от давления линейна. Этот факт используется для калибровки датчика всего по 2 точкам. После выбора на шаге 2 пункта «Pressure» и проверки правильности всех подключений появится следующее диалоговое окно:
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В качестве одного опорного давления удобно выбрать атмосферное давление, что соответствует на приведенной картинке точке1. Для получения значения АЦП, измеряющего давление, в этой точке необходимо нажать на соответствующую кнопку «Read ADC». При этом прочитанное значение АЦП должно быть равно 0 либо близко к 0. Далее датчик давления откачивается. Давление необходимо оценивать по эталонному манометру. После чего в блоке соответствующему второй точке необходимо указать измеренное давление и нажать на соответствующую кнопку «Read ADC». Полная откачка соответствует значению АЦП ~50 000 – 60 000. После нажатия на кнопку «Ok» автоматически высчитываются и загружаются в устройство соответствующие калибровочные коэффициенты. Нажатие кнопки «Close» приводит к закрытию окна без загрузки данных в устройство.

Калибровка датчика температуры. 
Для калибровки датчика температуры необходимо иметь полную калибровку термометра записанную в виде текстового файла. Значения T-R должны приводиться парами через Tab, Первым должно стоять значение температуры (температура должна быть выражена в кельвинах) и за ним следовать значение сопротивления (сопротивление должно быть выражено в килоомах). Помимо этого необходимо еще 2 точных резистора разного номинала (номиналы резисторов должны находиться в пределах изменения сопротивления термометра). Калибровка датчика температуры проходит в 2 этапа. Первоначально мы производим калибровку измерителя сопротивления, на втором этапе делается поправка на неточность зондирующего тока и формирование измерительной таблицы.

Калибровка омметра

Для калибровки омметра на шаге 2 необходимо выбрать режим «Temperature». После проверки правильности подключения появится диалоговое окно, похожее на окно появляющееся при калибровке датчика давления:
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Калибровка сводится к поочередному подключению резисторов. В поле «Resistor» для соответствующей точки измерения необходимо указать номинал резистора, после чего нажать на кнопку «Read ADC». После проведения измерения для двух точек по нажатию на кнопке «Ok» автоматически происходит вычисление коэффициентов для линейной аппроксимации показаний АЦП. Рекомендуется подключать резисторы с номиналами в диапазоне 50-150 кОм.
Получение поправки зондирующего тока и формирование измерительной таблицы.
Схема стабилизации зондирующего тока термометра может иметь небольшие погрешности. Это может привести к существенным погрешностям при измерении температуры. Ошибка может составлять несколько десятых кельвина. Для этой цели необходимо получить поправку к величине зондирующего тока. Для этой цели мы калибруем термометр по какой-нибудь стабильной температуре. В качестве такой температуры можно выбрать температуру кипения жидкого гелия (~4.2К). Поскольку температура кипения жидкого гелия является зависящей от атмосферного давления величиной и при изменении давления в пределах нормы может меняться более чем 0.1К, удобно выбрать в качестве калибровочной температуры λ-точку He (2.17К).

Для начала калибровки необходимо выбрать режим калибровки на шаге2 «Table R(T)», после чего появится следующее окно:
[image: image66.emf]
В поле «T_Termometer(K)» необходимо указать температуру термометра, после чего на жать на кнопку «Read CB». В поле «ADC Value» появится значение сопротивления термометра.

Для удобства хранения и вычисления температуры по показаниям АЦП в памяти МК строится таблица значений показаний АЦП и соответствующих им температурах. Таблица ограничена в размерах. Используется только 100 точек, при этом шаг по температуре выбран логарифмическим и покрывающим весь интересующий диапазон. Для формирования этой таблицы после введения поправки тока необходимо нажать на кнопку «Open Table». В появившемся диалоговом окне открыть текстовый файл с заранее подготовленной калибровкой термометра. После этого в поле, находящемся ниже кнопки появляется уже пересчитанная таблица готовая к загрузке в МК. Загрузка осуществляется по нажатию кнопки «Ok».

Работа с менеджером калибровок (CalibrManager.exe), загрузка и выгрузка калибровок.

Менеджер калибровок (программа CalibrManager.exe) предназначена для загрузки-выгрузки калибровок устройства, а также для записи калибровок в постоянную память. После работы с программой calibr.exe необходимо запустить менеджер калибровок и произвести все необходимые действия для записи данных в память. Для записи данных, а постоянную память сделана специальная программа поскольку в ходе калибровки могут возникать ошибки, которые могут испортить уже существующие калибровки, находящиеся в памяти устройства. Запись калибровок в постоянную память устройства следует проводить только при полной уверенности необходимости этого. Внешний вид программы представлен на рисунке выше. В полях указаны значения соответствующих коэффициентов. Получить их с устройства можно получить, нажав на кнопку «Download», после изменения констант вручную, новые калибровки можно поместить в устройство нажатием на кнопку «Upload».

Таблица показаний АЦП термометра и соответствующие им температуры могут быть загружены нажатием на кнопку «Get Table», после изменения таблицы она может быть помещена в память устройства нажатием на клавишу «Put Table». В программе сделана возможность записи калибровок на компьютер с последующей их загрузкой. Данная опция позволяет в случае сбоя калибровки использовать калибровку выполненную ранее. Запись в постоянную память осуществляется по нажатию на кнопку «SaveEEPROM». Процесс записи в постоянную память занимает ощутимое время в ходе которого устройство не подает признаков жизни, следует обязательно дождаться окончания процесса. 
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История версий.

Rev. 1.0. Первая версия технической инструкции
Rev. 1.1. Из набора инструментов исключены программы Programer.exe, calibr.exe, CalibrManager.exe. В этой и последующих версиях функции этих программ выполняет программа Prefences.exe.
Внесены изменения в программу ControlCenter.exe. Теперь конфигурация устройства определяется автоматически. Также включена мультиприборность (возможность использования нескольких источников смещения сразу).

Библиотека biasbox.dll получила возможность выбора прибора для работы с ним, поддерживается мультиприборность.

Компоненты Labview поддерживают возможность выбора прибора, поддерживается мультиприборность.
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