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Введение.

Программа DataCenter.exe предназначена для сбора данных, отображения в гра-
фическом виде и их хранения. Изначально программа была написана для внутрен-
него пользования для работы с многоканальным вольтметром собственного произ-
водства "Corobo4ka". Со временем функциональность программы была расширена
и оказалось, что в ряде экспериментов она удобна не только для сбора данных, но
и для простейшей обработки получаемых величин. В настоящее время программа
подразумевает возможность подсоединения разнообразных приборов. Рабочее окно
программы представлено на рисунке 1.

Программа использует MDI технологию, при которой имеется главное окно про-
граммы и дочерние окна (далее будем называть их рабочими окнами программы). По
подобной же технологии устроены такие распространенные офисные приложения как
MS Word, MS Excel и другие. Материнское окно программы занимается управлением
всеми инициализированными приборами, сбором данных и распределением ее между
дочерними окнами, которые в свою очередь занимаются хранением и отображением
информации. Управление отдельными устройствами происходит посредством плаги-
нов. Подробнее о каждом из существующих плагинов смотри в разделе ”Настройки
плагинов устройств” на стр. 19.

Рис. 1: Основное окно программы.
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Установка програмного обеспечения.

Шаг 1. Для установки программы необходимо запустить файл setup_5_1_0.exe.
Внешний вид окна приветствия показан на рисунке 2. Для перехода на следующий
шаг необходимо нажать на кнопку Next.

Рис. 2: Окно приветствия программы установки.

Шаг 2. На шаге 2 предлагается выбрать путь для установки программы. По
умолчанию выбран путь ”C:/DATA Center”.

Шаг 3. Выбор режима установки. Вид программы установки на шаге 3 пред-
ставлен на рисунке 3. Пользователю доступны следующие режимы установки:

• Full installation – установка основной программы и всех плагинов;

• Compact installation – установка только основной программы;

• Compact installation include plugins for Scontel’s BiasUnit – установка основной
программы, включая плагины для работы с источником смещения BiasUnit
производства компании Scontel;
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• Compact installation include plugins for Corobo4ka – установка основной про-
граммы, включая плагины для работы с устройством Corobo4ka;

• Compact installation include plugins for Scontel’s Counter – установка основной
программы, включая плагины для работы с счетчиком электрических импуль-
сов производства компании Scontel;

• Compact installation include plugins for NRPZ21 – установка основной програм-
мы, включая плагин для работы с измерителем мощности NRPZ21 производ-
ства Rohde&Schwarz;

• Compact installation include plugins for Lock-in-amplifier SR830 – установка ос-
новной программы, включая плагин для работы с Lock-in-amplifier SR830 про-
изводства Stanfird Research System;

• Compact installation include plugins virtual TEST devices – установка основной
программы, включая плагины для работы с виртуальным устройством TEST;

• Custom installation – режим позволяющий самостоятельно выбирать необходи-
мые компоненты.

Рис. 3: Окно установки программы на шаге 3.

Шаг 4. На шаге 4 предлагается выбрать название рабочей группы, которая будет
отображаться в меню ”Пуск” .

Шаг 5. На шаге 5 предлагается проверить все настройки установки. После нажа-
тия на кнопку Install программа будет установлена с выбранными параметрами. На
рабочем столе появится ярлык программыDataCenter.exe, а файлы с расширением
*.dcd будут проассоциированы с основной программой.



Описание интерфейса программы.

Пункт меню File>New, а также кнопка открывают диалоговое окно создания
нового рабочего окна. Подробно описание особенностей работы с этим окном описано
ниже в разделе ”Создание нового рабочего окна” на стр. 11.

Пункт меню File>Open, а также кнопка вызывают стандартное диалого-
вое окно открытия файла. Файл должен иметь расширение *.dcd. Данные в файле
хранятся в закодированном виде и открыть этот файл возможно лишь программой
DataCenter.exe.

Пункт меню File>Save, а также кнопка используются для сохранения данных
в формате *.dcd. Если файл был открыт ранее, то старый файл будет перезаписан
новым. В случае, когда работа идет с абсолютно новым файлом, будет вызван стан-
дартный диалог сохранения данных, в котором пользователю будет предоставлена
возможность выбрать директорию для хранения файла и его имя.

Пункт меню File>Save as. . . предназначен для вызова стандартного диалога
сохранения данных, в котором пользователю будет предоставлена возможность вы-
брать директорию для хранения файла и его имя.

Пункт меню File>Print и кнопка вызывают стандартное диалоговое окно
печати на принтере и предназначено для печати активного рабочего окна программы.

Пункт меню File>Exit предназначен для выхода из программы. При выходе
пользователю будет представлена возможность сохранить данные.

Пункт менюTools>Reading, а также кнопка инициализируют подключенные
устройства и запускают чтение данных в соответствии с настройками подключенных
устройств. Повторный выбор пункта меню Tools>Reading или нажатие на кнопку

останавливает процесс чтения данных.
Пункт меню Tools>Recording, а также кнопка начинают процесс записи

данных. При этом возникает диалоговое окно, показанное на рис. 4. В диалоговом
окне предлагается указать название для собираемого набора точек (далее кривой или
Curve). По умолчанию предлагается в качестве названия кривой указать текущую
дату и время. При нажатии на кнопку OK начинается запись данных во все окна,
открытых для записи. При этом в этих окнах добавляется кривая с соответствующим
названием. Нажатие кнопки Cancel отменяет процесс записи данных. Повторный
выбор пункта меню Tools> Recording или нажатие на кнопку останавливает
процесс записи данных.

Пункт меню Tools>Control Panel а также кнопка открывают боковую па-
нель индикации данных и управления подключаемыми приборами. Более подробно о
настройках боковой панели будет рассказано в раделе ”Элемент дерева ресурсов
Side Panel” на стр. 10 и в разделе в разделе ”Настройки плагинов устройств”
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Рис. 4: Окно выбора имени кривой.

на стр. 19.

Пункт меню Tools>Options, а также кнопка вызывают диалоговое окно
Options более подробно о возможностях этого окна и работе с ним рассказано в
разделе ”Описание диалогового окна Options” на стр. 7.

Пункт меню Tools>Plugin Manager вызывает диалоговое окно Plugin
Manager, показанное на рис. 5. В этом окне суммированна информация о всех под-
ключенных плагинах: имя плагина, его версия, краткая информация о назначении
плагина и тип плагина. Для плагинов, обеспечивающих взаимодействие с устрой-
ствами тип плагина - Device.

Рис. 5: Окно менеджера подключенных плагинов.

Пункт меню Window>Cascade, а также кнопка размещают все открытые
рабочие окна каскадом.

Пункт меню Window>Tile Horizontal, а также кнопка размещают все от-
крытые рабочие окна деля рабочий экран в горизонтальном направлении.

Пункт меню Window>Tile Vertical, а также кнопка размещают все откры-
тые рабочие окна деля рабочий экран в вертикальном направлении.

Ниже разделителя в пункте меню Windows расположены пункты меню, соот-
ветствующие названиям всех созданных рабочих окон. При выборе пункта меню,
соответствующее ему рабочее окно выйдет на передний план.

Пункт меню Help>Manual открывает данную инструкцию.
Пункт меню Help>About вызывает окно, в котором содержится краткая ин-

формация об авторе, а также история версий программы (на русском языке).



Описание диалогового окна Options.

Диалоговое окно Options вызывается при выборе пункта меню Tools>Options или

при нажатии кнопки на панели инструментов. При первом запуске программы,
при условии, что рабочие окна не созданы диалоговое окно Options выглядит как
показано на рисунке 6.

Рис. 6: Внешний вид окна Options.

В левой части диалогового окна Options располагается дерево ресурсов. Оно
представлено следующими элементами:Devices,Windows,Channels и Side Panel.
При выборе любого элемента дерево окно справа меняется.

Элемент дерева ресурсов Devices.
Элемент дерева Devices предназначен для добавления и удаления активных
устройств. В списке справа указаны все подключенные плагины, осуществляющие
взаимодействие с приборами. При двойном клике на соответствующем плагине по-
явится список поддерживаемых плагином устройств. Один и тот же плагин может
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поддерживать несколько типов устройств. Далее при двойном клике на соответству-
ющем типе устройства происходит автоматическое определение всех подключенных
устройств. В результате появится список доступных устройств, помченных серой пик-
тограммой. Для подключения конкретного устройства необходимо сделать двойной
клик на пиктограмме устройства. При успешном подключении устройства пикто-
грамма должна изменить свой цвет на зеленый. Также обновится и дерево ресурсов
в левой части диалогового окна Options. Подключенные устройства отображаются
ниже элемента Devices и помечены зеленой пиктограммой. Вид окна с подключен-
ными устройствами показан на рис. 7.

Рис. 7: Внешний вид окна Options при выбранном элементе ресурсов Devices и
подключенных устройствах.

Полоска прогресса в блоке Opacity настраивает прозрачность большинства диа-
логовых окон, используется в декоративных целях. Ниже описаны некоторые прибо-
ры, управление которыми реализовано к моменту написания этой инструкции.

Элемент дерева ресурсов Windows.
При выборе в дереве ресурсов элемента Windows появится окно с предложением
выбрать одно из рабочих окон для редактирования его настроек. Пиктограммы ра-
бочих окон располагаются ниже элемента Windows в дереве ресурсов. Детальное
рассмотрение настроек рабочих окон будет проведено в разделе ”Создание нового
рабочего окна” на стр. 11.
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Элемент дерева ресурсов Channels.
При выборе в дереве ресурсов элемента Channels появится окно показанное на рис.
8. Данная вкладка предназначена для использования псевдонимов входных каналов.
Это необходимо для более прозрачного отображения подключенных к приборам из-
меряемых величин. В правой части окна отображены каналы всех подключенных
устройств.

Рис. 8: Окно редактирования переменных.

По двойному щелчку мышки на любой из строк появляется диалоговое окно пред-
ставленное на рис. 9. Пользователю предоставляется возможность указать псевдоним
выбранного канала. При нажатии на кнопку Ok во всех рабочих окнах название ка-
нала будет заменено на его псевдоним и далее данные будут адрессоваться по этому
псевдониму. Для возвращения к исходному имени переменной необходимо в поле
выбора псевдонима не указывать ни одного символа.

Рис. 9: Окно редактирования псевдонима канала.
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Элемент дерева ресурсов Side Panel.
При выборе в дереве ресурсов элемента Side Panel появится окно показанное на
рис. 10. Эта вкладка предназначена для отображения данныхи включения панелей
управления приборами. В верхней части окна находится список всех принимаемых
переменных. Выставление флажка напротив имени переменной, приводит к измене-
нию вкладки Display на боковой панели. При дальнейшей работе программы эти
переменные будут постоянно отображаться. Это очень удобно при необходимости
следить за некоторыми важными переменными.

Рис. 10: Окно настройки боковой панели.

Кнопка Font приводит к открытию стандартного диалога форматирования
шрифта, что приводит к изменению шрифта отображения данных во вкладке
Display (рис. 11).

Рис. 11: Внешний вид вкладки Display.



Создание нового рабочего окна.

Пункт меню File>New, а также кнопка открывают диалоговое окно создания
нового рабочего окна, показанное на рис. 12. В верхней части диалогового окна пред-
ставлена таблица с основными настройками. В строке WindowType указывается
тип создаваемого окна. При нажатии на правой части этой строки возникает вы-
падающий список с возможностью выбора 3 типов создаваемого окна: 2DGraph,
3DGraph и 2DSteamGraph. При выборе типа 2D будет создано окно с двумя ко-
ординатами (X (горизонтальная ось) и Y (вертикальная ось)), при выборе типа окна
3D будет создано окно с тремя координатами (X (горизонтальная ось), Y (верти-
кальная ось) и ось Z, направленная перпендикулярно экрану монитора, при этом ин-
формация по этой оси отображается цветом), при выборе окна типа 2DSteamGraph
будет создано двумерное окно, в котором будет строится потоковые значения. Более
подробно о потоковых значениях выдаваемых плагинами смотри в разделеНастрой-
ки плагинов устройств на стр. 19.

Рис. 12: Диалоговое окно создания нового рабочего окна.

Строки Axis-X, Axis-Y и Axis-Z (последняя появляется в случае трехмерного
окна) показывают значение какой переменной будет отложено по данной оси.Щелчок
курсора мыши на строке приводит к появлению контекстного меню (см. рис. 13), при
этом пункта которого и определяется какой канал будет отображаться по данной
оси. Знак ’=’ в названии канала означает, что этой переменной назначен псевдоним,
стоящий после знака равенства.

Поле Background Color отвечает за фоновый цвет создаваемого окна (по умол-
чанию белый). Щелчок мыши на окрашенном элементе приводит к появлению выпа-
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Рис. 13: Диалоговое окно создания нового рабочего окна с контекстным меню выбора
канала оси.

дающего списка, в котором можно выбрать наиболее привлекательный пользователю
цвет. То же самое касается и полей Grid Color и Curves Color. Первое отвечает
за цвет сетки, второе за цвет кривых, которыми будут отображаться данные. После
можно будет выбрать индивидуальный цвет для каждой кривой.

В правой нижней части диалогового окна расположены 3 CheckBoxes. Галочка
Active показывает активно ли окно и готово ли оно для приема данных. При от-
ключении этой опции данные окном не принимаются. Галочка Write показывает бу-
дет ли производиться запись в это окно при выборе пункта меню Tools>Recording
или нажатии кнопки . Галочка StatusBas Visible указывает появится ли строка
состояния в нижней части созданного окна. Нажатие кнопки Ok приводит к созда-
нию рабочего окна, показанного на рис. 14. Для смещения сетки по горизонтали и
вертикали используются клавиши клавиатуры со стрелками. Также можно зажать
на колесико мышки и, передвигая ее, смещать координатную сетку. Изменять мас-
штаб координатной сетки по горизонтали или вертикали можно нажимая клавиши
клавиатуры со стрелками при нажатой клавише Shift.

В нижней части окна находится строка состояний, в которой отображается теку-
щее значение получаемых данных. Данные обновляются в момент, когда на каждую
из осей координат приходит не менее одного значения. После этого счетчик значений
для каждой оси сбрасывается. В центре экрана находится маркер. Маркер показыва-
ет текущее значение каждой из координат. Нажатие правой клавиши мыши на поле
рабочего окна приводит к появлению контекстного меню показанному на рис. 15.

Пункт меню Copy Curves копирует данные в буфер обмена данных в собствен-
ном формате программы. Данный пункт меню предназначен для переноса данных
из одного рабочего окна в другое.

Пункт меню Paste вставляет данные из буфера обмена данных, при этом данные
могут быть как в собственном формате программы, так и в текстовом формате (при
этом данные должны располагаться в 2 столбцах: первый - ось X, второй - ось Y
(в случае трехмерного окна, данные должны находиться в 3 столбцах), разделенные
либо пробелом, либо знаком табуляции, в конце каждой строке должен стоять символ
переноса строки).
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Рис. 14: Вид рабочего двумерного окна.

Рис. 15: Контекстное меню рабочего окна.

Пункт менюClearAll удаляет все существующие кривые.
Пункт меню CurvesManager открывает окно диспетчера кривых, показанное

на рис. 16. В списке слева перечислены все существующие кривые. Символы ле-
вее названия кривой означают следующее: первая пиктограмма - цвет кривой (по
щелчку курсором мыши на этой пиктограмме появляется контекстное меню, в ко-
тором можно выбрать цвет кривой), вторая пиктограмма - символ, обозначающий
видимость точек кривой (если кружок желтый, то точки видимы, черный кружок
означает невидимость точек кривой), щелчок курсором мыши на этой пиктограмме
меняет состояние видимости кривой на противоположное, последняя пиктограмма
- символ, показывающий соединены ли точки линией друг с другом (символ с ма-
леньким кружочком означает, что линии не соединяются друг с другом), щелчок
курсором мыши на этой пиктограмме меняет состояние соединенности точек кривой
на противоположное. Правее названия кривых указаны радиус точек (R) и шири-
на линии, соединяющих точки (W). Справа по центру расположены 3 строки ввода,
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позволяющие изменить название кривой, радиус точек, и толщину линии.

Рис. 16: Окно менеджера кривых двумерного окна.

В верхней правой части окна находятся кнопки позволяющие производить про-
стые действия с кривыми. Нажатие кнопки Join Curves приводит к объединению
выделенных кривых в одну, при этом все свойства (цвет, видимость, и т.д.) остаются
такими же как и у первой из выделенных в списке кривых.

Нажатие кнопки Delete или клавиши Del на клавиатуре приводит к удалению
выделенных кривых.

Нажатие кнопки Sort by X приводит к сортировке кривой по возрастанию ко-
ординаты X.

Нажатие кнопки Sort by Y приводит к сортировке кривой по возрастанию ко-
ординаты Y.

Кнопка A*X+B предназначена для проведения линейных трансформаций кри-
вых. При этом открывается диалоговое окно, показанное на рис. 17. Введя коэф-
фициенты в строки ввода и нажав на кнопку Do It, можно провести линейную
трансформацию выделенных кривых.

Рис. 17: Диалоговое окно, появляющееся при нажатии на кнопку A*X+B.

Следующие функции достаточно специфичны и вряд ли будут иметь широкое
практическое применение. Кнопка AVAR строит вариацию Алана от выделенных
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кривых. Math Calc производит вычисление среднего значения и среднеквадратич-
ного отклонения ординат выделенных кривых. AutoCORR строит автокорреляци-
онную функцию.

В нижней части окна расположены кнопки Save и Open. Эти кнопки предна-
значены для сохранения и чтения данных кривой в текствый файл. При нажатии
вызывается стандартный диалог, позволяющий отурыть файл для чтения или запи-
си.

Чуть ниже расположены кнопки Copy и Copy as Text. Первая предназначена
для копирования данных выделенных кривых в буфер обмена данных в собственном
формате. Вторая кнопка предназначена для копирования данных в буфер обмена
данных в текстовом формате с возможностью последующей вставки в текстовый
редактор. Между этими двумя процессами существует большая разница во времени
выполнения команд в пользу копирования в собственном формате.

Окно диспетчера кривых для трехмерных графиков несколько отличается. Оно
представлено на рисунке 18. Данные в трехмерных окнах могут отображаться двумя
способами - градиентная раскраска (при этом цвет точек плавно меняется от черного
до цвета кривой, обозначенного самой левой пиктограммой левее названия кривой,
черный цвет соответствует минимальному значению, цвет кривой - максимальному),
либо раскраска в цветах радуги (при этом фиолетовому цвету соответствует мини-
мальное значение, красному - максимальное). Выбор способа представления данных
производится по щелчку на самой правой пиктограмме левее имени кривой. Третья
слева пиктограмма отвечает за отображение точек, если она принимает вид квадра-
та, то точки отображаются прямоугольниками, со сторонами RX и RY соответствен-
но. В случае, когда эта пиктограмма принимает вид кружка, точки отображаются
в виде кругов с радиусом R. В строках ввода в правой части окна можно изменять
параметры кривой.

Рис. 18: Окно менеджера кривых трехмерного окна.

Назначение кнопок в правой части окна такое же как и для диспетчера кривых
двумерного рабочего окна. Появившаяся кнопка Gauss позволяет делать гауссово
размытие кривой. При нажатии этой кнопки возникает диалоговое окно (рис. 19).

Границы в которых происходит построение размытого изображения определяет-
ся полями Xmin, Xmax, Ymin, Ymax, при этом при размытии учитываются и точки
кривой вне выбранного прямоугольника. NX и NY определяют количество точек по
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Рис. 19: Диалоговое окно, появляющееся при нажатии на кнопку Gauss.

каждой из сторон прямоугольника, в котором происходит построение гауссова раз-
мытия. При этом общее число точек, в которых будет произведено вычисление равня-
ется NX*NY. sigmaX и sigmaY - параметры размытия по каждой из осей. Чем боль-
ше этот параметр, тем более размытым получится результат. Стоит выбирать эти
значения порядка среднего расстояния между точками кривой. По нажатию кнопки
Apply происходит вычисление матрицы, соответствующей размытому изображению.
Результат представляется в виде кривой. Использование этой функции удобно, когда
имеется ряд дискретных точек, а необходимо получить непрерывное изображение.

Вернемся к контекстному меню рабочего окна. При нажатии на пункт Selector
Enabled контекстное меню принимает вид, показанный на рис. 20.

Рис. 20: Контекстное меню рабочего окна.

При этом появляется возможность выбора точек прямоугольником при нажатой
левой клавиши мыши. Далее можно удалить точки внутри прямоугольника (Пункт
меню Delete) или вне прямоугольника (пункт меню Delete Outside).

Пункт меню Options соответствует выбору пункта меню Tools>Options или

нажатию на кнопку , с последующим выбором активного окна. При этом внешний
вид диалогового окна Options становится таким как показано на рисунке 21.

Блок Axises позволяет выбрать источник данных для соответствующей оси ра-
бочего окна. Щелчок курсором мыши на строках ввода в этом блоке приводит к
появлению контекстного меню, аналогичного тому, которое появляется в диалого-
вом окне создания нового окна.
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Рис. 21: Окно редактирования рабочего окна.

Блок Colors позволяет выбрать цветовую гамму для рабочего окна. Щелчок кур-
сором мыши на цветовой панели вблизи надписей BackGround,Grid и Curves при-
водит к появлению контекстного меню с возможностью выбора цвета. Выбранный
цвет будет установлен как основной для фона рабочего окна, координатной сетки и
цвета создаваемых кривых соответственно.

Блок Options позволяет изменять следующие свойства рабочего окна. Галочка
Active показывает активно ли окно и готово ли оно для приема данных. При отклю-
чении этой опции данные окном не принимаются. Галочка Write показывает будет
ли производиться запись в это окно при выборе пункта меню Tools>Recording или
нажатии кнопки . Галочка StatusBas указывает появится ли строка состояния в
нижней части созданного окна. Галочка Marker указывает на видимость маркера в
рабочем окне программы.

Все свойства рабочего окна меняются только после нажатия на кнопку Apply
или Ok в нижней части диалогового окна.

В центральной части окна находится блок линейной трансформации входных дан-
ных. В программе осуществлены 2 способа линейной трансформации входных дан-
ных. Первый способ подразумевает использование формулы X ′ = A × X + B для
каждой из осей, где коэффициенты A и B задаются пользователем. Второй спо-
соб связывает пару точек нетрансформированных данных с парой точек выходных
данных. Для расчета коэффициентов A и B необходимо нажать кнопку Solve и в
появившемся окне указать значения нетрансформированных переменных и соответ-
ствующие им выходные значения. Изменения вступают в силу только после нажатия
на кнопку Apply. Для трехмерных окон в этом блоке также указывается минималь-
ное и максимальное значения оси Z.
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ПРИМЕР:
Линейная трансформация вида 1000*X+0 вторым методом
будет записана как
Xold1 = 0
Xnew1=0
Xold2 = 1
Xnew2=1000



Настройки плагинов устройств.

Программа DataCenter.exe поддерживает большое количество различных
устройств. Плагины для программы постоянно обновляются, также добавляются
плагины новых устройств. Ниже приведено описание некоторых плагинов, входящих
в состав стандартной установки.

ВАЖНО: Программа установки не содержит драйверов устройств. Для полу-
чения драйверов обратитесь к производителям устройств.

Плагин BiasUnit.plg
Плагин BiasUnit.plg предназначен для работы с источником смещения ”BiasUnit”
производства компании Scontel. Устройство предназначено для запитывания сверх-
проводящих приемников SSPD (superconducting single photon detector) и HEB (hot
electron bolometer). Окно настроек устройства не содержит элементов управления.
Все управление устройством производится за счет контрольной панели, внешний вид
которой представлен на рис. 22.

Рис. 22: Панель управления устройством BiasUnit.

Плагин автоматически определяет включенные блоки устройства и отображает
только те панели, которые могут быть использованы в работе устройства. На ри-
сунке представлен пример для случая двухканального устройства смещения. В этом
случае, появляются 2 панели, каждая из которых предназначена для работы с соот-
ветствующим каналом источника смещения.
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В левой части панели управления располагаются 2 метки, позволяющие следить
за током и напряжением канала. Правее располагается 5 кнопок и колесико прокрут-
ки.

Кнопка ”Выбор режима” (помечена либо буквой I – режим стабилизации то-
ка, либо U – режим стабилизации напряжения) предназначена для сметы режима
стабилизации источника.

Кнопка ”Вкл./Выкл. закоротки” (помечена либо буквой S – образец закорочен,
либо O – образец раскорочен) предназначена для включения-выключения закоротки
детектора.

Кнопка ”Set0” устанавливает смещение в 0.
При нажатии на кнопку ”Set” вызывается диалоговое окно, позволяющее уста-

новить новое значение смещения детектора.
Колесико прокрутки предназначено для плавного изменения величины смещения

детектора. Для того чтобы им воспользоваться необходимо навести на него указатель
мыши и воспользваться колесиком прокрутки мышки. При нажатой клавише ”Ctrl”
скорость изменения смещения увеличивается в 5 раз.

При нажатии на кнопку ”Sweep” появляется дополнительная панель, показан-
ная на рисунке 23. Поле ”Start” предназначено для ввода начального значения пере-
стройки смещения, поле ”Stop” – для ввода окончания диапазона перестройки, поле
”Step” определяет шаг перестройки. При нажатии на кнопку ”Start” происходит за-
пуск развертки величины смещения, отановить которую можно по нажатию кнопки
”Stop” .

Рис. 23: Панель включения развертки BiasUnit.

Плагин предоставляет доступ для регистрации следующих каналов:
- I1 – ток канала 1;
- U1 – напряжение канала 1;
- I2 – ток канала 2;
- U2 – напряжение канала 2;
- P – показания датчика давления;
- T – показания датчика температуры;
- HEATER – напряжение источника питания печки;
- BATP – напряжение аккумуляторов, питающих устройство положительным напря-
жением;
- BATN – напряжение аккумуляторов, питающих устройство отрицательным напря-
жением.
В некоторых модификациях устройства часть каналов будет скрыта из-за отсутсвия
соответствующих датчиков в источнике смещения.
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Плагин Counter.plg
Плагин Counter.plg предназначен для работы с счетчиком производства компании
Scontel. Окно настроек устройства содержит несколько элементов управления. Преж-
де всего это время, в течении которого происходит счет импульсов (по умолчанию
0.1 с., минимально допустимое значение 0.01 с., максимально допустимое 655.35 с.) и
уровень компарации входного сигнала (по умолчанию 0 В, минимально допустимое
0 В, максимальнодопустимое 2.5 В).

Помимо этого, устройство может управляться с помощью боковой контрольной
панели. Вид панели практически совпадает с окном развертки BiasUnit, показан-
ным на рис. 23. Добавлена лишь кнопка ”Ref” , позволяющая быстро менять уровень
компарации.

Плагин предоставляет доступ для регистрации следующих каналов:
- Cnt – количество отсчетов счетчика в единицу времени;
- RefLvl – уровень напряжения компаратора.

Плагин Corobo4ka.plg
Плагин Corobo4ka.plg предназначен для работы с многоканальным устройством
”Corobo4ka”. Это самодельный быстрый 4-х канальный вольтметр, применяемый раз-
работчиком в простых измерениях. Выходными переменными плагина являются зна-
чения 4-х каналов, усредненные с выставленной постоянной времени, а также 2 пото-
ка данных: Osciloscope (данные с каждого из активных каналов в реальном време-
ни) и Spectrum (спектр каждого из активных каналов). Окно настроек устройства
”Corobo4ka” представлено на рисунке 24.

Рис. 24: Окно редактирования свойств устройства Corobo4ka.
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В блоке Channels находятся 4 CheckBox, в которых выбираются необходимые для
работы каналы измерительного устройства. Стоит учесть, что при уменьшении ко-
личества работающих каналов частота опроса каждого из каналов увеличивается об-
ратно пропорционально числу работающих каналов. В блоке Voltmeter&Spectrum
находятся элементы управления позволяющие менять настройки устройства счи-
тывания. Time Constant - время усреднения для работы вольтметра в режиме
самописца. Это время между двумя отображаемыми ближайшими точками любо-
го из каналов. Делать это время очень малым менее 20мс неправильно, поскольку
это приведет к существенной нагрузке на компьютер, к тому же точность опреде-
ления времени гарантированная операционной системой Windows порядка 10мс.
Conversion Time - время между двумя последовательными преобразованиями.
Диапазон значений этой величины 82-2600 мкс. Увеличение этой величины приво-
дит к уменьшению шумов преобразования и снижению максимальной частоты при
построении спектров. При этом максимальная частота спектра рассчитывается как
Fmax = 1/(2∗ConversionT ime∗NChannel), где NChannel - количество используемых
каналов. То есть при включенном одном канале и времени преобразования 1000 мс
максимальная частота спектра будет равна 500 Гц.

Параметры устройства изменяются при нажатии на кнопке Apply Options.
Блок Channel calibrating предназначен для калибровки на ноль каждого из

каналов вольтметра. При этом на вход вольтметра необходимо поместить закоротку
либо небольшое постоянное сопротивление, в выпадающем списке выбрать соответ-
ствующий ему номер канала и нажать на кнопку Calibrate. Это приведет к вычис-
лению новых калибровочных коэффициентов, хранящихся в памяти вольтметра и
дальнейшему их использованию при работе программы.

Для построения спектров используется вспомогательный плагин Spectrum.plg,
предназначенный для обработки данных и перенаправления обработанных данных
в основную программу. Для правильной работы плагина Corobo4ka.plg необходим
этот плагин.

Плагин предоставляет доступ для регистрации каналов ChX (X=0..3) - напряже-
ние на соответствующем входе устройства.

Плагин NRPZ21.plg
Плагин NRPZ21.plg предназначен для работы с измерителем мощности NRP-Z21
производства Rohde & Schwarz. Окно настроек измерителя мощности NRP-Z21 пред-
ставлено на рисунке 25.

Для настройки доступно лишь 3 параметра: Time Aperture – это время, в тече-
нии которого производится измерение мощности; N Averaging – параметр усредне-
ния, показывающий по скольки следующим друг за другом измренным величинам
мощности следует произвести усреднение. Галка Smoothing включает усреднение.

Параметры устройства изменяются при нажатии на кнопке Apply Options.
Плагин предоставляет доступ для регистрации следующих каналов:

- Power(W) – показания измерителя мощности, выраженные в Ваттах;
- Power(dBm) – показания измерителя мощности, выраженные в дБм.
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Рис. 25: Окно редактирования свойств измерителя мощности NRP-Z21.

Плагин SR830.plg
Плагин SR830.plg предназначен для работы с Lock-in Amplifier SR830 производства
Stanford Research System. Окно настроек прибора представлено на рисунке 26.

В блоке INPUT&FILTERS представлены настройки блока коммутации входа
прибора и входных фильтров. Выпадающий список Input Configuration предо-
ставляет возможность выбрать один из вариантов входной конфигурации: A, A-B,
I (1MΩ), I (100MΩ). Выпадающий список Ground позволяет подсоединить землю
измеряемого сигнала непосредственно к земле прибора, либо оставить ее плаваю-
щей. Выпадающий список Input Coupling позволяет выбрать режим согласования
проибора, при этом можно установить согласование по постоянному либо по пере-
менному току. Выпадающий список Filters позволяет выбрать входные фильтры
прибора (Line – фильтр на 50 Гц, 2xLine – 100 Гц).

В блоке GAIN&TIME представлены настройки блока обработки выходного сиг-
нала прибора. Выпадающий список Sensitivity предоставляет возможность выбрать
один из возможных режимов чувствительности прибора (2 nV/fA – 1 V/µA). Вы-
падающий список Reserve Mode позволяет установить данный режим в один из
следующих вариантов: High Reserve, Normal, Low Noise. Выпадающий список Time
Constant предоставляет возможность выбрать один из возможных режимов посто-
яннной времени прибора (10 µs – 30 ks). Выпадающий список low pass filter slope
позволяет выбрать крутизну выходного фильтра (6, 12, 18 или 24 дБ на октаву).
Галка SYNC (<200 Hz) включает синхронную фильтрацию возможного проник-
новения опорного сигнала в полезный сигнал. Работает данный режим только при
частотах опорного сигнала ниже 200 Гц.

В блоке Reference представлены настройки блока опорного сигнала. Выбор, ка-
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Рис. 26: Окно редактирования свойств Lock-in Amplifier SR830.

кой сигнал будет использоваться собственный прибора или внешний, определяется
выбором одной из радиокнопок (External – внешний опорный сигнал, Internal – внут-
ренний). При выборе в качестве рабочего внутреннего сигнала опоры открывается
возможность его тонкой настройки. Частота опорного сигнала задается полем Freq
(Hz), фаза – Phase (deg), выбор порядка гармоники, с которой прведется работа,
– Harmonic, амплитуда выходного сигнала опоры – LvL (V). Изменение характери-
стик опорного сигнала происходит только после нажатия на кнопку Set Reference.
Выбор триггера опорного сигнала осуществляется выпадающим списком Reference
trigger. При этом можно выбрать один из следующих вариантов: SIN – триггер по
пересечению нулевого уровня при синусоидальном опорном сигнале, POS EDGE –
триггер по возрастающему фронту опорного сигнала TTL, NEG EDGE – триггер по
падающему фронту опорного сигнала TTL.

Обновить все настройки, в случае ручного их изменения непосредственно на при-
боре, можно нажав на кнопку Update Options. Кнопки AutoGain, AutoPhase и
AutoReserve запускают процесс автоматического подбора чувствительности прибо-
ра, подстройки фазы сигнала и выбора режима резерва.

Поле Time to Read(msec) задает минимальное время между считываниями
показаний прибора. Изменения внесенные в это поле вступают только после нажатия
на кнопку Apply Options.

Управление прибором также возможно и с использованием боковой панели. Внеш-
ний вид боковой панели прибора показан на рисунке 27. С помощью боковой панели
можно изменять частоту, фазу или амплитуду опорного сигнала. Развертка по вы-
бранному в выпадающем списке параметру начинается после нажатия на кнопку
Start. Начальное значение разворачиваемой величины задается в поле Start, ко-
нечное – в поле Stop, шаг перестройки – в поле Step. Перестраивать выбранную
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величину можно как в линейном, так и в логарифмическом масштабах (выбор осу-
ществляется радиокнопками Lin и Log). Процесс развертки отражается в полосе
прогресса в нижней части панели управления. Остановить развертку можно в лю-
бой момент, нажав на кнопку Stop.

Рис. 27: Боковая панель управления Lock-in Amplifier SR830.

Плагин предоставляет доступ для регистрации следующих каналов:
- X – синфазная опоре составляющая сигнала;
- Y – составляющая сигнала задержанная на π/2;
- R – амплитуда сигнала;
- Theta –фаза сигнала;
- F – частота опорного сигнала.

Плагин TEST.plg
Плагин TEST.plg предназначен для работы с виртуальными тестовыми устройства-
ми. Плагин предназначен для моделирования процессов и отладки основной про-
граммы. При проверке наличия устройств должно обнаруживаться 2 устройства
Device#1 и Device#2. Каждое из устройств имеет 1 выходной канал Ch1 и 2 по-
токовых значение: Osciloscope и Spectrum. Для работы плагина необходим плагин
Spectrum.plg. Выходной сигнал представляет из себя шумовой сигнал с изменяе-
мыми значениями амплитуды шума и средним значением сигнала. В осцилограмму и
спектр сигнала также введена и грмоническая составляющая. Для настроек устрой-
ства используются следующие параметры:

• DT – время между 2-мя следующими друг за другом измерениями в мсек;

• V0 – среднее значение выходного сигнала;

• Vpp – peak-to-peak значение выходного сигнала;

Параметры устройства изменяются при нажатии на кнопке Update.
Тестовый плагин также снабжен и боковой панелью управления, в которой при-

сутствуют лишь 2 полосы прокрутки. Верхняя меняет V0, нижняя – Vpp.



История версий.

Ver. 5.1.0(20xx.xx.xx)
- Добавлена возможность загрузки новых плагинов с сервера при помощи
PluginManager.
- Добавлена возможность обновления программы и всех плагинов через интернет.
Ver. 5.0.5(2011.09.01)
- Изменен порядок управления статусом окна (активность и запись).
- Добавлен плагин SR830.plg.
Ver. 5.0.4(2011.08.15)
- Исправлены ошибка интерфейса, возникающая при открытии файла.
- Исправлена ошибка, возникающая при открытии связанных с программой файлов.
Ver. 5.0.3(2011.06.07)
- Реализован монитор значений. Теперь вы сможете следить за любыми изменениями
измеряемых программой значений.
- Реализованы элементы управления, позволяющие управлять плагинами в режиме
реального времени.
- Добавлен плагин BiasUnit.plg.
- Добавлен плагин Counter.plg.
Ver. 5.0.1(2011.05.27)
- Собран инсталятор программы.
- Реализованы все функции предыдущих версий на новой платформе с поддержкой
плагинов.
Ver. 5.0.0(2011.05.12)
- Первая версия программного обеспечения. Предыдущие версии были привязаны к
устройству Corobo4ka. Начиная с этой версии все внешние устройства входят равно-
правно и подключаются в виде плагинов.
Ver. 4.2.0(2010.04.05)
- Введена возможность использования нескольких устройств, в том числе.
– Corobo4ka.
– PowerMeter NRP-Z21.
– Lock-in amplifier SR830.
- Исправлено: При совпадении полного названия одной из переменных с частью на-
звания другой переменной может произойти сбой.
- Исправлено неправильное отображение нулевой вертикали и горизонтали.
Ver. 4.1.3(2009.12.27)
- Добавлена возможность обновления через интернет.
- Исправлена процедура чтения данных. Ранее возникали ошибки при одновремен-
ном использовании спектроскопа и самописца при условии, что время выборки для
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спектроскопа более чем в 2 раза меньше чем постоянная времени считывания дан-
ных.
Ver. 4.1.2b(2009.12.19)
- Переписаны процедуры вывода информации.
- Введена возможность приема внешней информации от других приложений
- Изменен формат записи файлов. Нынешняя версия записи файлов - V3. Предыду-
щие версии поддерживаются.
Ver. 4.1.1(2009.10.19) Использован новый компиллятор. Исправлены ошибки при
записи русских названий кривых. Исправлены ошибки использования буфера обме-
на данных. В предыдущей версии возникали ошибки при копировании и вставке
данных в текстовом формате.
Ver. 4.1.0(2009.05.08)
- введен новый формат записи файлов, с поддержкой старых форматов. Размер фай-
ла уменьшен на 20-25%, скорость записи увеличена в ∼7раз, скорость открытия фай-
лов увеличена в ∼4 раза.
- исправлены ошибки возникающие при печатии графиков.
- исправлена ошибка Selector.
- добавлена возможность выделения точек в трехмерных графиках при помощи
Selector’а.
- сделано общее меню всех настроек
- добавлена возможность отключения StatusBar в каждом окне
- добавлена возможность отключения Marker в каждом окне
Ver. 3.x.x.
Версия устройства 3. Более ранних версий программы не сохранилось.



Комплектация программного
обеспечения.

При установке программы в папку установки копируются следующие файлы:

• DataCenter.exe– основной исполняемый файл;

• borlndmm.dll – динамическая библиотека данных, осуществляющая распре-
деление памяти во время обмена данными между основной программой и пла-
гинами;

• borlndmm.dat – файл данных, необходимый для работы borlndmm.dll;

• Options.ini – файл настроек программы. Создается после выхода из програм-
мы и содержит информацию о конфигурации программы во время ее преды-
дущего запуска.

• BiasUnit.plg – плагин, предназначенный для работы с источником смещения
BiasUnit производства компании Scontel, находится в катологе Plugins.

• Counter.plg – плагин, предназначенный для работы с счетчиком электриче-
ских импульсов производства компании Scontel, находится в катологе Plugins.

• Corobo4ka.plg – плагин, предназначенный для работы с устройством
Corobo4ka, находится в катологе Plugins.

• NRPZ21.plg – плагин, предназначенный для работы с измерителем мощности
NRPZ21 производства Rohde&Schewarz, находится в катологе Plugins.

• SR830.plg – плагин, предназначенный для работы с Lock-in Amplifier SR830
производства Stanford Research Systems, находится в катологе Plugins.

• TEST.plg – плагин, предназначенный для работы с виртуальным устройством
TEST, находится в катологе Plugins.

• Spectrum.plg – плагин, предназначенный для обработки потоковых данных и
получения спектров, находится в катологе Plugins.

• Manual_RUS.pdf – файл с описанием программы и правил работы с ней,
находится в катологе Help.
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